Uploaded image for project: 'WebTop'
  1. WebTop
  2. WT-1041

Editor's resulting raw HTML differs from rendered one

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Medium
    • Resolution: Done
    • Mail
    • None
    • 5.9.0
    • develop
    • 5.12.9
    • wt-5.14.0
    • 0462

    Description

      In some situation sent email's HTML content is different from the one edited just before in editing view. We cannot see this ugly behaviour during editing because default styles are forced to editor's body: this practice pratically hides all issues related to editor formatting.

      Steps to reproduce:

      • Set default composition color in user settings to color different than black
      • Then open new message and type: aaa + ENTER + bbb + dotted-list + ENTER + ENTER + ccc + ENTER
      • Now wait the content to be saved to Drafts and check the preview

      Expected behaviour:

      • Text in message preview is fully painted using the choosen color

      Actual behaviour:

      • Text in message preview is NOT fully painted using the choosen color: "ccc" is in debault black while the above "aaa" and "bbb" are correctly set

      Attachments

        Activity

          People

            matteo.albinola Matteo Albinola
            matteo.albinola Matteo Albinola
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Packages

                Version Package